Search found 5 matches

by bocephus
Fri Mar 23, 2018 4:25 am
Forum: Diagnostic Help
Topic: no fuel pump, no spark, no power to fuse
Replies: 8
Views: 1441

Re: no fuel pump, no spark, no power to fuse

nope, i had the switch off and ran it manually with a screw driver. it was shot. i got the new switch in last night and all is well. thanks to those that helped!!!!!
by bocephus
Tue Mar 20, 2018 9:47 pm
Forum: Diagnostic Help
Topic: no fuel pump, no spark, no power to fuse
Replies: 8
Views: 1441

Re: no fuel pump, no spark, no power to fuse

alright guys....i think you hit the nail on the head. all info has helped me ALOT. 1. i dropped the steering wheel, found the switch, and watched the mechanical linkage. that all moves free 2. the switch's hardware was tight, thus the switch was not moving back and forth 3. i checked the wire connec...
by bocephus
Tue Mar 13, 2018 10:25 pm
Forum: Diagnostic Help
Topic: no fuel pump, no spark, no power to fuse
Replies: 8
Views: 1441

Re: no fuel pump, no spark, no power to fuse

The Berettas use an electronic switch UNDER the dash, mounted to the top of the steering column. The lock cylinder uses a multi-link mechanism to push/pull a rod that slides the contacts within this switch. The lock cylinder is probably fine, the switch is either loose or has gone bad. bocephus , w...
by bocephus
Sun Mar 11, 2018 9:33 pm
Forum: Diagnostic Help
Topic: no fuel pump, no spark, no power to fuse
Replies: 8
Views: 1441

no fuel pump, no spark, no power to fuse

so my 94 3.1L wont start. it cranks, but wont start. i couldnt hear the fuel pump, i have no fuel pressure, 0v input to the ignition control mod, and no spark on any of the 6 holes. like.....everything is DEAD. fuses are good (although no voltage to fuel pump fuse and ignition fuse). through my diag...
by bocephus
Mon Apr 11, 2016 8:08 am
Forum: General Questions
Topic: hard starting after engine is warm
Replies: 3
Views: 1250

hard starting after engine is warm

i have a 94 with the 3.1L engine. it starts like a champ when then engine is cold (ambient temp). but if i drive it xx miles and get it up to operating temp, shut the engine off, and go to restart it....i have to crank on it for 5+ seconds to get it to start (it always starts, it just starts hard wh...

Go to advanced search