Eibachs/GR-2's installed in the rear

Want some new struts? What brand springs to buy? How much camber to run? What brake pads? What's the best setup for your situation....
User avatar
lllusion
Registered User
Posts: 19
Joined: Mon Nov 07, 2005 12:46 pm
Location: Reading PA

Eibachs/GR-2's installed in the rear

Postby lllusion » Fri Mar 03, 2006 12:36 am

I just installed the GR-2's and the Eibachs this night (first the GR-2's drove to work 10 minutes away then when I got home put in the rear springs.

I have a question though, I am using the stock insulators for the springs right now and stock mounts for the shocks... Should I actually replace these???

The shock mounts didn't look bad at all but the insulators for the springs did look a little bit worn.. I took it out for a drive just to let them set in a little and I noticed some creaking sounds when taking off and also around turns but they quickly started to get less frequent but are still there... I have been told it could be my frame bushings themselves creaking but Is this just the springs setting into place??? I am going to get new insulators for them since its cake putting them in and out along with new top insulators.

I did make sure the springs were on correctly making sure not to slide out of the insulators at the top and bottom of them.

I am planning on putting the new struts on tomorrow.

EDIT: I forgot to mention I have a Z51 rear sway instead of the internal sway that came with it... The creaking was present before I swapped this in



0 to YAYYYYYY!
-W41 cams
-Fidanza Aluminum Flywheel
-Spec Stage III Lightened clutch
-Self Tuned EPROM via Moates
-KYB GR-2's all around
-Eibach Pro lowering springs

User avatar
IsaacHayes
Registered User
Posts: 975
Joined: Fri Oct 07, 2005 8:32 pm
Location: Missouri

Eibachs/GR-2's installed in the rear

Postby IsaacHayes » Fri Mar 03, 2006 1:59 pm

Hmm did the creaking start when you put on the Z51 bar? Make sure the inner mounts of the Z bar are farthest to the edges of the trailing arm/bar as they can go or it will move around on you and not do you much good. That might also cause noise. Perhaps put some silicone grease in the bushings and see if that helps...


Image Image 2010 project (click pic)
1994 3100 BERETTA. 200,000+ miles.
16.0 @ 84.41mph when stock. Now ???
Original L82 w/LA1, LX9, & LX5 parts!!!

soon to be OBD1 tuned...

User avatar
lllusion
Registered User
Posts: 19
Joined: Mon Nov 07, 2005 12:46 pm
Location: Reading PA

Eibachs/GR-2's installed in the rear

Postby lllusion » Fri Mar 03, 2006 5:30 pm

Creaking was present before Z51 which didn't make the noise increase or decrease.

I am pretty sure its the axle/frame bushings... figure the car is sitting lower so they are moving a little bit past where they would normally be... Also I noticed the creaking today when I would put the breaks on to come to a stop at a light... then SLOWLY accelerate and you would hear this dreadful creaking... the handling is solid just makes a little extra noise.

I am putting the front shocks/struts on tonight I will inspect the back to make sure everything is still in good shape.



0 to YAYYYYYY!
-W41 cams
-Fidanza Aluminum Flywheel
-Spec Stage III Lightened clutch
-Self Tuned EPROM via Moates
-KYB GR-2's all around
-Eibach Pro lowering springs

User avatar
IsaacHayes
Registered User
Posts: 975
Joined: Fri Oct 07, 2005 8:32 pm
Location: Missouri

Eibachs/GR-2's installed in the rear

Postby IsaacHayes » Sun Mar 05, 2006 8:10 pm

Perhaps the noise is coming from the front and not the rear?


Image Image 2010 project (click pic)
1994 3100 BERETTA. 200,000+ miles.
16.0 @ 84.41mph when stock. Now ???
Original L82 w/LA1, LX9, & LX5 parts!!!

soon to be OBD1 tuned...

User avatar
lllusion
Registered User
Posts: 19
Joined: Mon Nov 07, 2005 12:46 pm
Location: Reading PA

Eibachs/GR-2's installed in the rear

Postby lllusion » Mon Mar 06, 2006 10:49 am

Ha that sound coming from the back was off all things the exhaust rattling up against the axle where it goes over it... the hanger for the thrush glasspack broke along with one back at my muffler I had to coat hanger the **** up to prevent it from haning low... I will have to get it taken care of when I head to the exhaust shop with to get a new downpipe on my ported exhaust manifold.



0 to YAYYYYYY!
-W41 cams
-Fidanza Aluminum Flywheel
-Spec Stage III Lightened clutch
-Self Tuned EPROM via Moates
-KYB GR-2's all around
-Eibach Pro lowering springs

User avatar
IsaacHayes
Registered User
Posts: 975
Joined: Fri Oct 07, 2005 8:32 pm
Location: Missouri

Eibachs/GR-2's installed in the rear

Postby IsaacHayes » Mon Mar 06, 2006 11:30 pm

ah cool. Nice to figure out a problem, and it was nothing serious.

I have 3 mounts on my exhaust. The stock one before the muffler, a muffler strap from a 95+ model, and then the other stock mount that goes to the muffler, only that one I made an L braket out of stainless steel and clamped it to my tail pipe. (since my ultra-flo is shorter than the stock muffler. it's hidden, even though it's pretty) :)


Image Image 2010 project (click pic)
1994 3100 BERETTA. 200,000+ miles.
16.0 @ 84.41mph when stock. Now ???
Original L82 w/LA1, LX9, & LX5 parts!!!

soon to be OBD1 tuned...


Return to “Suspension and Brakes”

Who is online

Users browsing this forum: No registered users and 4 guests