Z-51 done!

Want some new struts? What brand springs to buy? How much camber to run? What brake pads? What's the best setup for your situation....
User avatar
Jeph
Registered User
Posts: 83
Joined: Tue Oct 14, 2003 11:52 pm
Location: Missing my GT
Contact:

Z-51 done!

Postby Jeph » Fri Sep 30, 2005 3:01 pm

after 2 days of fighting with one of the brackets, and cursing, scraping my arms, and yelling at the wife for her unwillingness to get greasy/dirty to help (she did help some), i finally got my sway bar put in. i tried using a cheater bar, WD-40 and elbow grease for everything i had, and just couldnt get inrternal one off. wifey torqued on it as well, (bear in mind, shes 6 ft 1 1/2, an amazon, and none of our efforts got the bolts for the internal bar to budge. sooooo.....we just cut the (red) brackets (the part that inserts into the axle) to fit around it.

it seemed like the sway bar MIGHT have been out of square a bit, because i had to use a clamp to get it to mount correctly on one side. while clamped, i threw the bolt on and tightened it. i was almost to the point of ditching the plastic insert (the flattened, curved piece at the bottom of the axle). definitely a noticed improvement in cornering, with just one trip around the block. $20 well spent!!  :banana

anyway, heres the pics...




edit: need to touch up that paint...







User avatar
Jeff P
Registered User
Posts: 534
Joined: Wed Sep 15, 2004 4:38 pm
Location: JBLM, WA
Contact:

Z-51 done!

Postby Jeff P » Fri Sep 30, 2005 8:52 pm

Alright, that's great!  Looks real good in red :)


-Jeff P.
Black '88 Beretta GT
Spice Red '06 GTO

Previously Owned:
'89 GT, '91 GT, '92 GTZ (12.95@105 mph), '01 Bonneville SSEi

User avatar
berettaspeed
Registered User
Posts: 84
Joined: Wed Jun 18, 2003 10:50 pm
Location: Milwaukee,WI
Contact:

Z-51 done!

Postby berettaspeed » Fri Oct 07, 2005 10:33 pm

now you need exhaust upgrade. LOL


Best ET 14.313@95.37 N/A
Best MPH 14.438@95.71 N/A
89GT 5spd
3400MPFI & Boost
:wave

User avatar
Jeph
Registered User
Posts: 83
Joined: Tue Oct 14, 2003 11:52 pm
Location: Missing my GT
Contact:

Z-51 done!

Postby Jeph » Sat Oct 08, 2005 2:15 pm

well, coincidently, the exhaust was done by a guy with a 93 or 94 base beater. he said he couldnt put anything above 2" on because there wasnt enough space between underside of car, and axle with stock bends. that it would bump into the axle when i hit a bump. im assuming either he was lazy, or my springs are weak, or something...  :hammer



User avatar
1988GTU
Registered User
Posts: 2744
Joined: Sat Mar 23, 2002 1:06 pm
Location: A town up north
Has thanked: 18 times
Been thanked: 11 times

Z-51 done!

Postby 1988GTU » Sat Oct 08, 2005 8:21 pm

He's full of $#!^.
2-3/4" can be made to fit.


_________
Image
-------------

User avatar
IsaacHayes
Registered User
Posts: 975
Joined: Fri Oct 07, 2005 8:32 pm
Location: Missouri

Z-51 done!

Postby IsaacHayes » Tue Oct 11, 2005 9:14 pm

How come you cut out the stock inner bar? On my 94 the Z51 bolted right up no problems at all. Make sure the inner plastic brakets are pushed far as possible to the edges and the bar works best. (looks like they are).

The rear doesn't twist as much, and going over speed bumps/higher parking lots doesn't make the car rock as bad too. I love sway bars.


Image Image 2010 project (click pic)
1994 3100 BERETTA. 200,000+ miles.
16.0 @ 84.41mph when stock. Now ???
Original L82 w/LA1, LX9, & LX5 parts!!!

soon to be OBD1 tuned...

User avatar
Jeph
Registered User
Posts: 83
Joined: Tue Oct 14, 2003 11:52 pm
Location: Missing my GT
Contact:

Z-51 done!

Postby Jeph » Wed Oct 12, 2005 3:58 pm

i didnt cut the stock inner bar out, i cut the red brackets to fit around the bar. you can see a bolt head in the first pic that looks wet, to the left of the bracket that wraps around the axle. thats from the WD-40 that didnt work...the bolts on too tight.




Return to “Suspension and Brakes”

Who is online

Users browsing this forum: No registered users and 2 guests