1994 3500 6 Speed ZR6

Tell us about your Beretta and Post an Image
User avatar
SummitBalt08
Registered User
Posts: 1062
Joined: Fri Jun 04, 2010 11:10 am
Location: Sidney, Ohio
Has thanked: 2 times
Been thanked: 3 times
Contact:

Re: The trip into the

Postby SummitBalt08 » Mon Jun 02, 2014 2:25 pm

Here's what it came up with you were right about the code

Image

Image

Image



Sent from my EVO LTE using Tapatalk 2
Last edited by SummitBalt08 on Tue Feb 02, 2016 3:01 pm, edited 1 time in total.


-Shawn
Been on the Beretta Forums since '04
Image
94 Black Quad 5 spd Z26 ->3500 6 spd ZR6

Bfests '11,'12,'14
July 2012 Bnet Calendar

User avatar
3X00-Modified
Administrator
Posts: 10664
Joined: Thu Jul 05, 2007 9:18 am
Location: Plainfield CT
Has thanked: 12 times
Been thanked: 46 times

Re: The trip into the "big leagues" ..running and driving!

Postby 3X00-Modified » Mon Jun 02, 2014 3:41 pm

1655 can be ignored because you didn't tell me you were removing the Evap system so I never disabled that code, I will do that at Bfest. The 1200 I've never seen tripped before but I've also never had injectors go bad. I'm concerned that it could be an issue somewhere else though and maybe just a short... But it could be a bad injector. And the TPS code you need to figure out ASAP... that's very critical when it comes to 90% of how the car runs, if it's seeing a very poor TPS signal then a lot of your tuning will be off and you will get hesitation when you step on the gas as well as erratic idle and such.



User avatar
SummitBalt08
Registered User
Posts: 1062
Joined: Fri Jun 04, 2010 11:10 am
Location: Sidney, Ohio
Has thanked: 2 times
Been thanked: 3 times
Contact:

Re: The trip into the

Postby SummitBalt08 » Mon Jun 02, 2014 3:46 pm

3X00-Modified wrote:1655 can be ignored because you didn't tell me you were removing the Evap system so I never disabled that code, I will do that at Bfest. The 1200 I've never seen tripped before but I've also never had injectors go bad. I'm concerned that it could be an issue somewhere else though and maybe just a short... But it could be a bad injector. And the TPS code you need to figure out ASAP... that's very critical when it comes to 90% of how the car runs, if it's seeing a very poor TPS signal then a lot of your tuning will be off and you will get hesitation when you step on the gas as well as erratic idle and such.



I changed the TPS sensor and the code still gets triggered. James and i have no idea why its still there. I have erased the code after we replaced the sensor and it keeps coming back. Not sure if it has something to do with the TCE tb or what.

The evap system is getting installed this weekend also. I have everything except for one line that I am picking up from the yard.

Do you have any input to fix the TPS? Its annoying lol

Sent from my EVO LTE using Tapatalk 2
Last edited by SummitBalt08 on Tue Feb 02, 2016 3:01 pm, edited 1 time in total.


-Shawn
Been on the Beretta Forums since '04
Image
94 Black Quad 5 spd Z26 ->3500 6 spd ZR6

Bfests '11,'12,'14
July 2012 Bnet Calendar

User avatar
3X00-Modified
Administrator
Posts: 10664
Joined: Thu Jul 05, 2007 9:18 am
Location: Plainfield CT
Has thanked: 12 times
Been thanked: 46 times

Postby 3X00-Modified » Mon Jun 02, 2014 4:17 pm

It's more than annoying it can be detrimental and dump the ecu in limp mode. I'd start by checking the wiring harness really good for continuity to the ecu from the sensor.



User avatar
SummitBalt08
Registered User
Posts: 1062
Joined: Fri Jun 04, 2010 11:10 am
Location: Sidney, Ohio
Has thanked: 2 times
Been thanked: 3 times
Contact:

Re: The trip into the "big leagues" ..running and driving!

Postby SummitBalt08 » Mon Jun 02, 2014 6:04 pm

3X00-Modified wrote:It's more than annoying it can be detrimental and dump the ecu in limp mode. I'd start by checking the wiring harness really good for continuity to the ecu from the sensor.


I will see if James can look at that otherwise I don't know.

Sent from my EVO LTE using Tapatalk 2


-Shawn
Been on the Beretta Forums since '04
Image
94 Black Quad 5 spd Z26 ->3500 6 spd ZR6

Bfests '11,'12,'14
July 2012 Bnet Calendar

User avatar
Money pit Beretta
Registered User
Posts: 6353
Joined: Thu Jul 26, 2007 11:36 am
Location: Kansas
Has thanked: 2 times
Been thanked: 8 times

Re: The trip into the "big leagues" ..running and driving!

Postby Money pit Beretta » Mon Jun 02, 2014 6:28 pm

Had my TPS's main power wire break at the connector. It was down to just a few strands. Lucky for me it was easy to see once I checked into it. The 90GT had TPS problems so the first thought was to change the sensor. That seemed to help an then it was back to acting up. I gave the wires a tug and out came most of the power wire. The ground and ref wires were still good and I guess they were holding the power wire in place.


keep'em flying!

User avatar
Cliff8928
Administrator
Posts: 1773
Joined: Wed Mar 03, 2004 10:03 pm
Location: Long Grove, IL
Has thanked: 8 times
Been thanked: 10 times
Contact:

Re: The trip into the "big leagues" ..running and driving!

Postby Cliff8928 » Tue Jun 03, 2014 4:03 am

That's pretty good for a generic scanner like that to have that good of a description. Can you view your PIDs and see what your TPS value is? Maybe the minimum air flow rate is set wrong?
Attachments
P0122.jpg


Cliff Scott
Image

User avatar
SummitBalt08
Registered User
Posts: 1062
Joined: Fri Jun 04, 2010 11:10 am
Location: Sidney, Ohio
Has thanked: 2 times
Been thanked: 3 times
Contact:

Re: The trip into the "big leagues" ..running and driving!

Postby SummitBalt08 » Wed Jun 04, 2014 12:51 pm

Cliff8928 wrote:That's pretty good for a generic scanner like that to have that good of a description. Can you view your PIDs and see what your TPS value is? Maybe the minimum air flow rate is set wrong?


I'm not sure. I am going to set up my DHP so I can see what its reading with that and have James check over the wiring.


-Shawn
Been on the Beretta Forums since '04
Image
94 Black Quad 5 spd Z26 ->3500 6 spd ZR6

Bfests '11,'12,'14
July 2012 Bnet Calendar

User avatar
SummitBalt08
Registered User
Posts: 1062
Joined: Fri Jun 04, 2010 11:10 am
Location: Sidney, Ohio
Has thanked: 2 times
Been thanked: 3 times
Contact:

Re: The trip into the "big leagues" ..running and driving!

Postby SummitBalt08 » Wed Jun 04, 2014 12:55 pm

I got all the parts I need today. I was surprised it all showed up as fast as it did.

Brand new shift cables from GM, full set of trailblazer rebuilt/flow matched injectors and DEI heat shroud to protect the shift cables from heat. Hopefully this is the last time I have to buy parts for awhile lol

Image
Image
Image

Getting those put in along with the foglight bulbs to match my headlights on Saturday.

Also supposed to have a couple guys from V6Z24 visit on Saturday surprisingly. I guess there's a guy from that group about a half hour from me that I didnt know about.
Last edited by SummitBalt08 on Tue Feb 02, 2016 3:02 pm, edited 1 time in total.


-Shawn
Been on the Beretta Forums since '04
Image
94 Black Quad 5 spd Z26 ->3500 6 spd ZR6

Bfests '11,'12,'14
July 2012 Bnet Calendar

User avatar
3X00-Modified
Administrator
Posts: 10664
Joined: Thu Jul 05, 2007 9:18 am
Location: Plainfield CT
Has thanked: 12 times
Been thanked: 46 times

Re: The trip into the "big leagues" ..running and driving!

Postby 3X00-Modified » Wed Jun 04, 2014 1:38 pm

Make sure you investigate that TPS issue otherwise you'll just be chasing your tail.



User avatar
SummitBalt08
Registered User
Posts: 1062
Joined: Fri Jun 04, 2010 11:10 am
Location: Sidney, Ohio
Has thanked: 2 times
Been thanked: 3 times
Contact:

Re: The trip into the "big leagues" ..running and driving!

Postby SummitBalt08 » Sat Jun 07, 2014 9:33 pm

Didnt get as much done as I hoped to today but did get the TPS issue fixed, evap installed and the new injectors in. Its a whole different car now has way more power than it did before.


-Shawn
Been on the Beretta Forums since '04
Image
94 Black Quad 5 spd Z26 ->3500 6 spd ZR6

Bfests '11,'12,'14
July 2012 Bnet Calendar

User avatar
GTZryda
Registered User
Posts: 185
Joined: Mon Sep 04, 2006 2:06 pm
Location: Smyrna Delaware
Contact:

Re: The trip into the "big leagues" ..running and driving!

Postby GTZryda » Sat Jun 07, 2014 9:46 pm

Well you can't post that the tps issue is fixed with telling use what fixed it?!?


90 GTZ W41
96 Z26
96 Twin cam
Image

User avatar
SummitBalt08
Registered User
Posts: 1062
Joined: Fri Jun 04, 2010 11:10 am
Location: Sidney, Ohio
Has thanked: 2 times
Been thanked: 3 times
Contact:

Re: The trip into the "big leagues" ..running and driving!

Postby SummitBalt08 » Sat Jun 07, 2014 10:11 pm

Sorry it was a long day with everything that was going on outside of getting the car done. Found bad wiring so cut some wiring from my parts car and soldered it in. No check engine light at all now. Throttle body was adjusted also and doesnt stick anymore so to say.
Last edited by SummitBalt08 on Tue Feb 02, 2016 3:02 pm, edited 1 time in total.


-Shawn
Been on the Beretta Forums since '04
Image
94 Black Quad 5 spd Z26 ->3500 6 spd ZR6

Bfests '11,'12,'14
July 2012 Bnet Calendar

User avatar
SummitBalt08
Registered User
Posts: 1062
Joined: Fri Jun 04, 2010 11:10 am
Location: Sidney, Ohio
Has thanked: 2 times
Been thanked: 3 times
Contact:

Re: The trip into the

Postby SummitBalt08 » Mon Jun 09, 2014 4:21 am

Jon got all the problems fixed. Drove it for awhile and it was still idling high after warm-up.

After driving it for about a half hour off and on.. this code popped up right before I pulled it in the garage.

Would this be just because the tune needs tweaked?

Image

Sent from my EVO LTE using Tapatalk 2
Last edited by SummitBalt08 on Tue Feb 02, 2016 3:03 pm, edited 1 time in total.


-Shawn
Been on the Beretta Forums since '04
Image
94 Black Quad 5 spd Z26 ->3500 6 spd ZR6

Bfests '11,'12,'14
July 2012 Bnet Calendar

User avatar
SummitBalt08
Registered User
Posts: 1062
Joined: Fri Jun 04, 2010 11:10 am
Location: Sidney, Ohio
Has thanked: 2 times
Been thanked: 3 times
Contact:

Re: The trip into the

Postby SummitBalt08 » Mon Jun 09, 2014 4:30 am

I didn't take as many pics as I should have, but it was a very productive weekend.

Crossover got wrapped, new injectors installed, new shift cables installed with the heat shroud over them, new thermostat (runs a lot cooler now), new foglight housings and bulbs are in, and got the new hole for the cigarette lighter drilled.

Also changed the oil twice. Since there was a lot of gas in the motor from the stuck injector.. changed the oil once and drove it easy for a bit Saturday... Then today changed the oil again. That was an expensive thing to do since I use Mobil 1 but am being safe.

Still have to put in the 96 brake pedal cruise switch and that's about it aside from the damn e brake which I guess I won't have again.



Image

Image

Image

Image





Sent from my EVO LTE using Tapatalk 2
Last edited by SummitBalt08 on Tue Feb 02, 2016 3:03 pm, edited 1 time in total.


-Shawn
Been on the Beretta Forums since '04
Image
94 Black Quad 5 spd Z26 ->3500 6 spd ZR6

Bfests '11,'12,'14
July 2012 Bnet Calendar


Return to “Members Rides”

Who is online

Users browsing this forum: No registered users and 9 guests