DTMAce's 95 Black Base - THE BAMBI KILLER! - New Pics 5-1!

Tell us about your Beretta and Post an Image
User avatar
DTMAce
Registered User
Posts: 3510
Joined: Thu Sep 25, 2008 7:03 pm
Location: Michigan EUP
Contact:

Re: DTMAce's 95 Black Base - THE BAMBI KILLER! - New Pics 5-

Postby DTMAce » Mon Jun 18, 2012 5:53 pm

Ok, some new updates today finally.

Image

Image

Image

Replacement Fender after getting straightened some. Have to test fit it.

Image

Hood after initial sanding and base primer. Needs more sanding and more primer, then a final sand and paint. Yay.

Image

As it sat less than 2 hours ago.

Image

Removed the hood and fender, this was about a half hour ago.

Image

One wrinkled fender please!

Image

New and old hood. Hard to believe I managed to get the same color! lol

Image

More car.

Image

Fender area without fender or inner liner.

Image

Test fit of the replacement fender. Needs more tweaking, then I can sand it.


List to have done before I leave on Wednesday morning:

Hood and fender installed.
Lower drivers side trim piece back on.
New inner fender liner.
Horn.
Hood latch.
Lower latch assembly.
Headlight supports.
Headlights.
Grill.
Sand, prep and shoot paint on all the rusted areas around the fender lips.
Finish putting the interior back together. (I had the console out)
Replace the driver's side seat covers.
Install new red Beretta decal for windshield. If I can find it.
Install headlight covers.
Swap the wheels to the original base wheels, complete with covers. (Tires are junk on the ARs right now)
Replace the door mirrors (if I have time).
Remove the drip cover on the passenger door so both sides match.
Thoroughly clean the interior and exterior.

LOL

Lots to do! Hope to have the hood painted later tonight, and the fender at least ready for paint if not painted as well.


94' Z26 Project - 95' Base Project - Custom LED Light Conversions!
Chosen Proposal Submission & Committee Member for Beretta Fest 2012 in Traverse City Michigan

Image
Image

User avatar
DTMAce
Registered User
Posts: 3510
Joined: Thu Sep 25, 2008 7:03 pm
Location: Michigan EUP
Contact:

Re: DTMAce's 95 Black Base - THE BAMBI KILLER! - New Pics 5-

Postby DTMAce » Mon Jun 18, 2012 9:39 pm

Well, thank you mother nature.

I have been delayed a bit, hopefully I can get stuff painted in the morning. I did get the horn installed, and a few other things, but it was raining like a bitch out here. And not in a nice way at all.


94' Z26 Project - 95' Base Project - Custom LED Light Conversions!
Chosen Proposal Submission & Committee Member for Beretta Fest 2012 in Traverse City Michigan

Image
Image

User avatar
DTMAce
Registered User
Posts: 3510
Joined: Thu Sep 25, 2008 7:03 pm
Location: Michigan EUP
Contact:

Re: DTMAce's 95 Black Base - THE BAMBI KILLER! - New Pics 5-

Postby DTMAce » Tue Jun 19, 2012 9:40 pm

Damn I'm tired tonight. But I actually managed it:

Image

Image

Image

Image

Image

Image

Image

Image

Image

Image

Image

Image

Image

Image

I have nothing to say for each picture. But its together anyway. Some things I did not get to do, but oh well. Who knows we can have a parking lot fixit or something later.. LOL

So yeah, I will be rolling in this, one way or another. Leaving first thing in the morning. Bringing some extra stuff with me as well. Anyone need anything, let me know.


94' Z26 Project - 95' Base Project - Custom LED Light Conversions!
Chosen Proposal Submission & Committee Member for Beretta Fest 2012 in Traverse City Michigan

Image
Image

96B-Mike
Registered User
Posts: 440
Joined: Fri Sep 10, 2010 9:45 am
Location: Tampa,FL

Re: DTMAce's 95 Black Base - THE BAMBI KILLER! - New Pics 5-

Postby 96B-Mike » Sat Jun 23, 2012 9:53 pm

geeze you been through alot..glad you decided stick to it and repair it..good work!


Image

User avatar
DTMAce
Registered User
Posts: 3510
Joined: Thu Sep 25, 2008 7:03 pm
Location: Michigan EUP
Contact:

Re: DTMAce's 95 Black Base - THE BAMBI KILLER! - New Pics 5-

Postby DTMAce » Sat Jun 23, 2012 11:00 pm

Yep. Drove it to bfest, been running all over TC in it, heading back up tomorrow afternoon.


94' Z26 Project - 95' Base Project - Custom LED Light Conversions!
Chosen Proposal Submission & Committee Member for Beretta Fest 2012 in Traverse City Michigan

Image
Image

User avatar
1988GTU
Registered User
Posts: 2744
Joined: Sat Mar 23, 2002 1:06 pm
Location: A town up north
Has thanked: 18 times
Been thanked: 11 times

Re: DTMAce's 95 Black Base - THE BAMBI KILLER! - New Pics 5-

Postby 1988GTU » Sun Jun 24, 2012 12:04 am

Holly poop you have some bald tires!


_________
Image
-------------

User avatar
DTMAce
Registered User
Posts: 3510
Joined: Thu Sep 25, 2008 7:03 pm
Location: Michigan EUP
Contact:

Re: DTMAce's 95 Black Base - THE BAMBI KILLER! - New Pics 5-

Postby DTMAce » Sun Jun 24, 2012 12:33 am

Actually, they are not bald, they are dry rotted. The tire tread is designed to look like slicks at the outside edge, but they still have plenty of tread. However the tires are all severely dry rotted and the tread portion is starting to come away from the belted section. So they are still junk.

But they have been this way since I bought the car, and I have been careful. Not to mention I have a second set of wheels in the backseat, just in case.


94' Z26 Project - 95' Base Project - Custom LED Light Conversions!
Chosen Proposal Submission & Committee Member for Beretta Fest 2012 in Traverse City Michigan

Image
Image

2.2H8TA
Registered User
Posts: 915
Joined: Mon Aug 31, 2009 3:59 am
Location: NE-PA
Contact:

Re: DTMAce's 95 Black Base - THE BAMBI KILLER! - New Pics 5-

Postby 2.2H8TA » Sun Jun 24, 2012 5:58 am

Did you, or do you plan to do any underbody rust repair? Glad to see it's still going strong.


1994 AQUA ZED

User avatar
DTMAce
Registered User
Posts: 3510
Joined: Thu Sep 25, 2008 7:03 pm
Location: Michigan EUP
Contact:

Re: DTMAce's 95 Black Base - THE BAMBI KILLER! - New Pics 5-

Postby DTMAce » Sun Jun 24, 2012 8:39 pm

Well, it was. Now, its not running at all. Pulled the coil pack spark wiring, found corrosion on two of them, the coils measure 6.9k, 5.9k, and 6.0k. The 6.9 is the one with all the corrosion really bad, and has been replaced before. However.

The engine sounds like its trying to destroy itself, despite the coil being corroded. So I find it difficult to believe its just that. Almost suspect the timing chain has jumped a tooth possibly. Will pull the coils, clean them good, see what I have then. Problem is, I need to know the order of the spark wires... I assume it goes left to right, back to front, but I'm not certain.

At least it died after I got to my destination. LOL Will see what I can find out tomorrow.


94' Z26 Project - 95' Base Project - Custom LED Light Conversions!
Chosen Proposal Submission & Committee Member for Beretta Fest 2012 in Traverse City Michigan

Image
Image

User avatar
1988GTU
Registered User
Posts: 2744
Joined: Sat Mar 23, 2002 1:06 pm
Location: A town up north
Has thanked: 18 times
Been thanked: 11 times

Re: DTMAce's 95 Black Base - THE BAMBI KILLER! - New Pics 5-

Postby 1988GTU » Sun Jun 24, 2012 9:11 pm

Hope this helps:
Image


_________
Image
-------------

User avatar
DTMAce
Registered User
Posts: 3510
Joined: Thu Sep 25, 2008 7:03 pm
Location: Michigan EUP
Contact:

Re: DTMAce's 95 Black Base - THE BAMBI KILLER! - New Pics 5-

Postby DTMAce » Sun Jun 24, 2012 10:38 pm

Actually had a buddy that works on cars all the time, had him take a look and found 3 bad spark cables. One was jumping sparks to a bolt on the upper intake (saw the orange flash from inside the car while he was checking the noise. All the coils are firing at least. One cable has a broken/corroded end, one actually has the wiring showing through the cable housing! I was like wtf. How did I miss all that? And how has it been running all this time? LOL

Will get you all some pics of this nightmare later on.


94' Z26 Project - 95' Base Project - Custom LED Light Conversions!
Chosen Proposal Submission & Committee Member for Beretta Fest 2012 in Traverse City Michigan

Image
Image

User avatar
DTMAce
Registered User
Posts: 3510
Joined: Thu Sep 25, 2008 7:03 pm
Location: Michigan EUP
Contact:

Re: DTMAce's 95 Black Base - THE BAMBI KILLER! - New Pics 5-

Postby DTMAce » Mon Jun 25, 2012 12:59 pm

Ok, replaced the wires. Better, but still hammering like a bastard. Collapsed lifters maybe? Noise is harsh and multiple, and according to my friend up here, it sounded top end.. Engine shakes in the bay pretty hard. But it will idle now without dying, though barely. If I had to guess, its down at least 2 cylinders. We tested spark last night, all 6 coil points were firing. But I had 3 bad wires, so I bought new ones today and verified the pattern.

Again, the car was running perfectly when I got here with it yesterday. It's literally like someone threw a switch and broke it.


94' Z26 Project - 95' Base Project - Custom LED Light Conversions!
Chosen Proposal Submission & Committee Member for Beretta Fest 2012 in Traverse City Michigan

Image
Image

User avatar
Money pit Beretta
Registered User
Posts: 6353
Joined: Thu Jul 26, 2007 11:36 am
Location: Kansas
Has thanked: 2 times
Been thanked: 8 times

Re: DTMAce's 95 Black Base - THE BAMBI KILLER! - New Pics 5-

Postby Money pit Beretta » Mon Jun 25, 2012 1:04 pm

Yeah man the lifters do tend to go bad on a 3100.


keep'em flying!

User avatar
Chad91GTZ
Registered User
Posts: 1354
Joined: Thu Dec 23, 2004 8:32 pm
Location: Lomira, WI

Re: DTMAce's 95 Black Base - THE BAMBI KILLER! - New Pics 5-

Postby Chad91GTZ » Mon Jun 25, 2012 2:38 pm

How's your oil pressure? Lifters getting the juice? If you have valve clatter that could be a cause.


Image
My Motortopia

Bfest Committee 2012, 2013, 2014
Bfest AND Bust 2012 Winner: First ever clutch swap at Berettafest!
Bfest 2013 Watermelon Award: Boob shaped hood dents FTW

User avatar
DTMAce
Registered User
Posts: 3510
Joined: Thu Sep 25, 2008 7:03 pm
Location: Michigan EUP
Contact:

Re: DTMAce's 95 Black Base - THE BAMBI KILLER! - New Pics 5-

Postby DTMAce » Mon Jun 25, 2012 3:01 pm

I don't have any idea of how much oil pressure there is, outside of knowing the needle is pegged. So I have pressure, but it could be high or low. When you turn the key to just on, the needle is usually at the bottom. Even while cranking it will jump and peg. So it appears to me that the oil pump is engaging at least. My first thought was that maybe I snapped the cam or something.

As of right now, I have no idea what to do. If it were just the lifters, I would almost be willing to risk it, if I could limp it back home, but I doubt it would last long doing that.

At least I have it idling better, now that I changed the spark wires.


94' Z26 Project - 95' Base Project - Custom LED Light Conversions!
Chosen Proposal Submission & Committee Member for Beretta Fest 2012 in Traverse City Michigan

Image
Image


Return to “Members Rides”

Who is online

Users browsing this forum: No registered users and 6 guests