rear defogger problem

Archived topics from the Diagnostic Help Forum
Guest

rear defogger problem

Postby Guest » Fri Dec 28, 2001 10:23 am

Hello guys!!!. I have a 1990 gt and one of the options is the rear defogger. Now this thing doesn't work at all, the light comes on but it won't work. I already checked it and I have power and ground but it still won't work. What should I do? Replace the backglass or try and fix the one i've got?

thanks!!!

carlos
1990 yellow indy
5sp, 116,xxx, analog dash
(for sale or trade):)



Guest

rear defogger problem

Postby Guest » Fri Dec 28, 2001 5:15 pm

Look for breaks in the metal grid. They have repair kits at the autoparts store. Did you check the voltage at the switch, or the connections on the rear window?
One of the connectors broke on my old car, and I  ended up soldering it back together.



Guest

rear defogger problem

Postby Guest » Tue Jan 01, 2002 11:08 pm

Well, There are several brakes in the metal grid. What should i do now?. Replace the entire blackglass?



Guest

rear defogger problem

Postby Guest » Tue Jan 01, 2002 11:12 pm

NO. go to your local auto parts store and tel them you need the kit for repairing the rear defogger.  They should know what your after. I think the kit is around 20 bucks or so.  There is a thread on this same issue in the Mobile ELectronics Section.

good ideas and info too.



Guest

rear defogger problem

Postby Guest » Wed Jan 02, 2002 12:59 am

theyre under 10bux for the kit.




Return to “Diagnostic Help Archive”

Who is online

Users browsing this forum: No registered users and 1 guest