Z26 automatic trans, overdrive problems

Archived topics from the Diagnostic Help Forum
Guest

Z26 automatic trans, overdrive problems

Postby Guest » Mon Mar 03, 2003 2:54 pm

Z26, 3100 , 4 speed Auto, shifts fine 1, 2, 3, won't go into overdrive, oil is fine,

when cruising at 100 km/h , and release gas , rmp drops like it did shift, press on gas and rmp goes back to 3 rd gear status

any help in diagnosis would be helpful

thanks



Guest

Z26 automatic trans, overdrive problems

Postby Guest » Mon Mar 03, 2003 2:57 pm

sounds bad like a shift valve is stuck, or 4th gear clutch pack is toast, or low fluid (doubt it), I would be willing to bet JCZ26 would be more of a help..either way it sounds bad.



User avatar
wicked-irocz
Registered User
Posts: 1028
Joined: Thu Feb 20, 2003 11:21 pm
Location: South Central MN

Z26 automatic trans, overdrive problems

Postby wicked-irocz » Mon Mar 03, 2003 4:13 pm

Is this all the time or just one time?  I had my transmission not shift into OD once, and I was really scared that Id need a new trany.  The fluid looked like it could be a little burnt, but not much, and the level was fine.  I didnt change anything and a few days later drove it to find it shifted great.  Seams as if the only thing wrong was that the fluid got a little to hot, one of my friends owns a trany shop and said that could very well be but recomended me to change the fluid.  I will change the fluid when it warms up for sure.  Seams that driving around town with 800 lbs in a Beretta for an extended period of time isnt a good idea


94 Beretta Z26 57,4xx miles
3100, auto, crank windows, power locks/trunk, A/C,
To many mods to list
-intercooler :shock:

Among beretta boards
1st Turbo 4t60-e
1st Turbo 3100
1st Turbo Z26
1st 94+ Turbo

Guest

Z26 automatic trans, overdrive problems

Postby Guest » Mon Mar 03, 2003 4:21 pm

whats the 800lbs?



User avatar
wicked-irocz
Registered User
Posts: 1028
Joined: Thu Feb 20, 2003 11:21 pm
Location: South Central MN

Z26 automatic trans, overdrive problems

Postby wicked-irocz » Mon Mar 03, 2003 5:08 pm

People, supplies, and a few things that accumulate in the trunk of a car.


94 Beretta Z26 57,4xx miles
3100, auto, crank windows, power locks/trunk, A/C,
To many mods to list
-intercooler :shock:

Among beretta boards
1st Turbo 4t60-e
1st Turbo 3100
1st Turbo Z26
1st 94+ Turbo

Guest

Z26 automatic trans, overdrive problems

Postby Guest » Tue Mar 04, 2003 8:29 am

Wife drives it, Very cold here in maritimes, engine light came on and out, car sluggish for a few minutes she said, next morning light was off when she started it, I drove the car 5 days later and I noticed this problem, I took it for a few good runs since, still no shifting into overdrive, no burned smell, oil level good, a little old by the color, will change oil and filter tonite, to see if it changes, I beleive it is a stuck valve. Will keep ya posted



Guest

Z26 automatic trans, overdrive problems

Postby Guest » Tue Mar 04, 2003 9:08 am

Quote
I beleive it is a stuck valve.
Doubt it, will elaborate when I have more time.



Guest

Z26 automatic trans, overdrive problems

Postby Guest » Fri Mar 07, 2003 12:31 pm

I beleive I found my problem, a stuck solenoid,



http://www.atcdg.com/TechMain.htm




Return to “Diagnostic Help Archive”

Who is online

Users browsing this forum: No registered users and 2 guests