Possible fuel injector?

Archived topics from the Diagnostic Help Forum
Guest

Possible fuel injector?

Postby Guest » Wed Jun 11, 2003 8:42 pm

Today I drove my 91 gt w/3.1  down to Rockford Illinois which is about 30 miles away. She drove fine all the way down although she did feel a bit sluggish. When i got to the movie theater, I noticed the car was idling really rough. I drove across the street to the gas station and popped the hood. Everything seemed fine til I got to the rear sparkplug bank where I found the middle one was fairly loose. I drove back to the theater and let it sit to cool down. After the movie, I pulled the wire and hand tightened the plug as much as I could, replaced the boot and drove home.  I also noticed it ran really really bad in reverse. When I got home I replaced the plugs and the wires. Started it up and no change. Still idles rough and sounds like crap when I rev it up, almost a backfiring like sound. I also noticed fuel smell in the air. Could I have a bad, clogged injector? Something else? Any advice would be greatly appreciated.  Thanks-JoeBoo



Guest

Possible fuel injector?

Postby Guest » Wed Jun 11, 2003 9:57 pm

I just went out with an old wire and a used plug to check for spark. There wasn't any spark from the number three coil post but I was getting spark  from the other post on the same coil pack. Don't coil packs usually go out all the way? Just replace that one pack and that should fix everything right? Any thoughts would be greatly appreciated. Thanks-JoeBoo



Guest

Possible fuel injector?

Postby Guest » Thu Jun 12, 2003 9:54 am

sound sliek a coil pack shorted out--but it may have taken the module too. TRy just the coil pack first but don't be surprised if it took out the module too.



User avatar
gtuturbo
Registered User
Posts: 255
Joined: Sat May 05, 2001 12:15 am
Location: SW Michigan
Contact:

Possible fuel injector?

Postby gtuturbo » Thu Jun 12, 2003 11:33 pm

Quote (BerettaGT/14ASEcerts @ June 12 2003,08:54)
sound sliek a coil pack shorted out--but it may have taken the module too. TRy just the coil pack first but don't be surprised if it took out the module too.

Yes, most likely. I had an Accel coil arcing to ground through a crack in the casing and caused a nice miss. Was on the way to Memphis Berettafest last year. :(
Replaced the coil and the module died two days later. Fixed that and it has run fine since.
Moral of story-- don't buy Accel junk! ...and their customer service sucks!  :angry:


Paul Keller
1988 Chevrolet Beretta GTU (turbocharged) (bought new in August 1988)
1966 Oldsmobile Cutlass Convertible
2017 Jeep Patriot High Altitude
2015 Buick Encore
2015 GMC Acadia SLE-1


Return to “Diagnostic Help Archive”

Who is online

Users browsing this forum: No registered users and 3 guests