Page 1 of 1

Trouble Shooting Guide

Posted: Sun Feb 13, 2005 7:24 pm
by bryan
I made this up a few years ago with the help of a haynes manual. It can be helpful

http://www.beretta.net/how_to....le.html

Trouble Shooting Guide

Posted: Sun Feb 13, 2005 8:58 pm
by 1988GTU
It will help the newbies.

Trouble Shooting Guide

Posted: Sun Jun 05, 2005 2:12 pm
by Guest
I have a 1990 GT 3.1.

The check engien light has come on from time to time with my egnoring it.  Now the ar is very hard to start, runs with NO power at all, smoke ing exhost, and a lot of soot under the hood.  The soot seems to be coming from the back top of the engien on the drivers side.  H E L P

Did I kill this thing. Or what? :(

Trouble Shooting Guide

Posted: Mon Jun 06, 2005 6:37 am
by Jeff P
Sounds like the EGR (Exhaust Gas Recirculation) valve area.  Check to see if anything is unhooked or disconnected in that area.  It's possible there is a loose hose or tube or something.

Trouble Shooting Guide

Posted: Fri Feb 24, 2006 12:38 pm
by wht89gt
hey guys hellllllllllpppppppp i rebuilt my 2.8 in my beretta back to stock figured i would do this till i get the money saved up to build a 3.1 or bigger its all back together and in the car eveything is hook up right but the car will start up run for about 30 sec. and die i look in my hayes manual and checked the conections on the coil pack (all are good) checked for leaks around plenum and throttle body and still nothing checked fuel pressure and it is all over the place fron 40 psi to start drops (after car is running )to35 and back up to almost 50 is this a sign that the fuel pump is going bad or is it something else ???

Trouble Shooting Guide

Posted: Fri Feb 24, 2006 3:17 pm
by Asylum
It's more likely the fuel regulator if the pressure is all over the place like that.
Might be the fuel filter too. Ever changed it?

Trouble Shooting Guide

Posted: Mon May 15, 2006 11:32 pm
by reggie
I was driving down the freeway cruise control on at 65 mph. All of a sudden the cruise shut off and the speedometer quit working. When I got to the surface strrets the car would idle rough and die unless I gave it additional fuel, the check engine light came on. After sitting a few hours I started the car to drive home and it ran fine the speedometer worked for about 12 blocks and quit again, the car started running rough and the cruise would not work. Any ideas on what's wrong, how to fix it, and what part or parts are causing the problem.

Thanks Reggie

Re: Trouble Shooting Guide

Posted: Thu Feb 20, 2014 9:54 pm
by davbell25413
Link doesnt work.