Loud noise from left side

Have a flashing light? Gauges acting funny? Bad idle? Get your problems solved...
Guest

Loud noise from left side

Postby Guest » Tue Nov 01, 2005 3:11 pm

I got a loud screeching noise coming from the left side by the belt. It used to go away when I turned on my AC and I wouldnt hear it anymore. This worked for about a month or so now it wont go away. It almost sounds like the water pump pully but my car never overheats or runs bad. It wont always do it at first some times it takes a couple minutes for the car to get warm. Any ideas or anyone ever had this happen to them...??/ Need help



User avatar
1988GTU
Registered User
Posts: 2744
Joined: Sat Mar 23, 2002 1:06 pm
Location: A town up north
Has thanked: 18 times
Been thanked: 11 times

Loud noise from left side

Postby 1988GTU » Tue Nov 01, 2005 3:59 pm

Could be the alt or a/c unit becoming/is faulty.
Is you surp belt tight?
Leaking any fluids onto the belt/pulleys?
Check it out.


_________
Image
-------------

Guest

Loud noise from left side

Postby Guest » Tue Nov 01, 2005 7:55 pm

No leaking fluids, belt is not wet. Just replaced belt when changing alt. and it id tight. Sounds almost like a high piched grinding noise like a squeal.?? Dont know it sounds like the water pump anyone have this happen before??



User avatar
woody90gtz
Registered User
Posts: 4032
Joined: Thu Jul 11, 2002 8:45 pm
Location: Walton, NY
Has thanked: 4 times
Been thanked: 7 times
Contact:

Loud noise from left side

Postby woody90gtz » Tue Nov 01, 2005 8:31 pm

A/C clutch. I can almost guarantee it. Mine's shot too. It's quite common.


Image
91 "SS" 3400/5spd - EP, FFP, TCE, SPEC, DSS, S&S, OBD1, 13s? GEARHEAD dezign


Return to “Diagnostic Help”

Who is online

Users browsing this forum: No registered users and 3 guests