egr code

Have a flashing light? Gauges acting funny? Bad idle? Get your problems solved...
Guest

egr code

Postby Guest » Tue Oct 11, 2005 1:20 am

I have a 1994 Beretta 3100 with 79000 miles.
 Car has for quite awhile set off the check engine light indicateing egr trouble-----usually during decelleration on the highway(when backing off throttle after a pass,etc.)
  The car runs fine and has never shown any ill-effects from the egr system malfunctioning.
 The dealer told me after they checked it that it was indicateing the number 2 motor in the egr was just a nano-second slow in responding.
  The light goes off usually before I shut down and always is off when I restart the car.It also may run for many miles before coming on in the above mentioned circumstance.
   Sometimes it doesn't come on at all for a few days.
    I have tried 2 bone-yard egr's in an effort to keep from buying a new one.Both donors have done the same thing as the original egr valve.
    My question is-is there any other thing that could cause that light to indicate egr symptons besides the egr valve itself.?The egr passages have been thoroughly cleaned out as well.
   The dealer told me that the particular problem would noty cause any trouble down the road --does any one know if they are right about this?
   thanks



User avatar
IsaacHayes
Registered User
Posts: 975
Joined: Fri Oct 07, 2005 8:32 pm
Location: Missouri

egr code

Postby IsaacHayes » Tue Oct 11, 2005 4:24 pm

Only problem it causes is that stupid SES light on your dash. I've had the problem and cleaned out my passages, but then the EGR soleniod clogs every so often.

You can try taknig it off and running carb cleaner through it and moving the pistons up and down with an awl. That may help it some but sooner or later it will mess up again.

Only way to totaly make it work good is get a new EGR, but those are very $$$ if I recall, that's why I try to put up with the stupid SES light... I even though about relocating the light so it doesn't blind me at night, but I could still tell that it's throwing a code.....


Image Image 2010 project (click pic)
1994 3100 BERETTA. 200,000+ miles.
16.0 @ 84.41mph when stock. Now ???
Original L82 w/LA1, LX9, & LX5 parts!!!

soon to be OBD1 tuned...

backwoodzberetta
Registered User
Posts: 62
Joined: Tue Mar 30, 2004 10:42 pm
Location: Columbus Ohio
Contact:

egr code

Postby backwoodzberetta » Tue Oct 11, 2005 6:56 pm

Check the passage first to make sure it isn't blocked.  You can clean the egr but sometimes it's just a temporary fix to an ongoing problem.  You can check the valve like so.



Ground the leads one at a time.


-Nick

This car has 223,000 miles on it and gets 37 mpg highway.

RIP  In it's last stages of life.

User avatar
IsaacHayes
Registered User
Posts: 975
Joined: Fri Oct 07, 2005 8:32 pm
Location: Missouri

egr code

Postby IsaacHayes » Tue Oct 11, 2005 7:17 pm

It may be the solinods going bad but it maybe also chunks of carbon sticking them. Cleaning it realy well will help some. But they all get dirty and stick eventually.


Image Image 2010 project (click pic)
1994 3100 BERETTA. 200,000+ miles.
16.0 @ 84.41mph when stock. Now ???
Original L82 w/LA1, LX9, & LX5 parts!!!

soon to be OBD1 tuned...

Guest

egr code

Postby Guest » Tue Oct 11, 2005 10:20 pm

i cleaned the valve and the passages-by the way my 91 lumina euro 3.1 has the same valve and it has never failed , nor thrown a code in 182000 miles(knock on wood) .
 If it doesn't cause any trouble in doing what it is doing -i think I will ignore it instead of spending a hundred and fifty bucks for a new one right now.
 I just thought it strange that each boneyard one would malfunction in the same manner,but knowing my luck -it really doesn't surprise me much. :cool:




Return to “Diagnostic Help”

Who is online

Users browsing this forum: No registered users and 6 guests