3400 install. My Z26 is slightly less crappy!

Want to know how to get more out of your Beretta? Or have a mod you would like to share?
User avatar
Godlike
Registered User
Posts: 176
Joined: Tue Apr 08, 2008 10:02 am
Location: Stoughton, Wi
Contact:

Re: 3400 install. My Z26 is slightly less crappy!

Postby Godlike » Wed May 15, 2013 8:13 pm

Made a prototype rocker patch at work last night. Thinking about spotwelding the pinch weld and removing the side skirts to drill and rivit the outside. I can bend about 50" at a time.
Image


90' GTZ 189whp NA 14.00@99 / 237whp 50 shot 13.3@104 /95' Integra 225whp / 69' Impala / 04' Z71 Tahoe/ 85 G20/ 15' IS350F
projects 86 Bonneville 6.0 swap / MkIII Supra LS1 swap

User avatar
Godlike
Registered User
Posts: 176
Joined: Tue Apr 08, 2008 10:02 am
Location: Stoughton, Wi
Contact:

Re: 3400 install. My Z26 is slightly less crappy!

Postby Godlike » Wed May 29, 2013 10:29 pm

scannerman wrote:Glad to see the car is getting restored. I remember the treck to NC in that beast. It desperately needed the 3400 swap.


LOL, ya I rememeber three of us heading to NC with the car packed to the roof. At one point I floored it up a steep hill in the mountins and we were doing 50mph and loosing speed while the temp. gauge was rising to the danger zone.


90' GTZ 189whp NA 14.00@99 / 237whp 50 shot 13.3@104 /95' Integra 225whp / 69' Impala / 04' Z71 Tahoe/ 85 G20/ 15' IS350F
projects 86 Bonneville 6.0 swap / MkIII Supra LS1 swap

User avatar
Godlike
Registered User
Posts: 176
Joined: Tue Apr 08, 2008 10:02 am
Location: Stoughton, Wi
Contact:

Re: 3400 install. My Z26 is slightly less crappy!

Postby Godlike » Wed May 29, 2013 10:42 pm

Put a new tank and pump in yesterday.


Image


Depinned my old map plug and installed a new one.

I havent delt with the rad. fan not coming on issue yet but the car runs pretty cool with out it. Chad said he found a spot on the block to run the one wire gauge sensor that produced a close enough reading but I havent looked into that much yet. Also Ive since recharged my AC system so I can controll the fan with that for now.

Got most of the loose ends tied up for Bfest. My tires have seen better days but there not getting replaced anytime soon. The first layer of cords is just an early warning anyways.


90' GTZ 189whp NA 14.00@99 / 237whp 50 shot 13.3@104 /95' Integra 225whp / 69' Impala / 04' Z71 Tahoe/ 85 G20/ 15' IS350F
projects 86 Bonneville 6.0 swap / MkIII Supra LS1 swap

User avatar
Rettax3
Registered User
Posts: 1080
Joined: Mon Oct 22, 2012 3:34 pm

Re: 3400 install. My Z26 is slightly less crappy!

Postby Rettax3 » Thu May 30, 2013 12:20 am

Godlike wrote:Put a new tank and pump in yesterday.


Image


Depinned my old map plug and installed a new one.

I havent delt with the rad. fan not coming on issue yet but the car runs pretty cool with out it. Chad said he found a spot on the block to run the one wire gauge sensor that produced a close enough reading but I havent looked into that much yet. Also Ive since recharged my AC system so I can controll the fan with that for now.

Got most of the loose ends tied up for Bfest. My tires have seen better days but there not getting replaced anytime soon. The first layer of cords is just an early warning anyways.

Nice looking tank. Glad to see metal going in there... My '90 is the only Beretta in my family with a plastic tank. :roll: Oh well, no issues with it yet.
Edit: Wasn't even thinking about it -both Indys should have plastic tanks too!
The rear-bank drain-plug (for the coolant-jackets) is the same size/thread as the gauge temp-sender on the older cars, I never checked, but I bet it is more than deep enough for the sensor. I just put 3.1 heads on my 3400, so no issues there! %) (Except for reduced flow, although my heads are ported-out enough they come close, and with the turbo and headers, it doesn't much matter anyway, and the increase in compression-ratio is not unwelcome. :wink: )

Sounds like the car is really coming along quite nicely, I wish I could have made BFest this year... Oh well. Your tires do sound a little scary though. :no: I wouldn't take exposed cords at any speed for an extended distance like that, but you know your car better than I do, so what do I know? Good luck.
Last edited by Rettax3 on Thu Jun 13, 2013 10:18 pm, edited 1 time in total.


1989 Super Charged 3800 Series II (First)Six-Speed Conversion GTU
1990 Turbo 3.4 Five-Speed T-Type
1990 4.0L 4-Cam 32-Valve V-8 Five-Speed Indy GTi (Rebuild Project)
1990 Stock(!) 3.1 MPFI Auto Indy
1995 3400 Top-End Auto OD Z-26

User avatar
Godlike
Registered User
Posts: 176
Joined: Tue Apr 08, 2008 10:02 am
Location: Stoughton, Wi
Contact:

Re: 3400 install. My Z26 is slightly less crappy!

Postby Godlike » Thu Jun 13, 2013 8:01 pm

Got 31.5mpg on a trip to Chicago 2 weeks ago. Not bad but I would like to try to get it a little higher.
Replaced the 12vdc outlet with one off an Integra as they are 5/16" deeper and wont spit out my GPS charger plug.
Pretty much ready for Denver. Were leaving for Colorado Springs saturday. Hopefully our hotel isn't on fire or something
Image
All cleaned up and ready for the ball


90' GTZ 189whp NA 14.00@99 / 237whp 50 shot 13.3@104 /95' Integra 225whp / 69' Impala / 04' Z71 Tahoe/ 85 G20/ 15' IS350F
projects 86 Bonneville 6.0 swap / MkIII Supra LS1 swap

User avatar
heavywoody
Global Moderator
Posts: 1849
Joined: Sun Nov 03, 2002 4:10 pm
Location: Concord, NC
Has thanked: 8 times
Been thanked: 15 times
Contact:

Re: 3400 install. My Z26 is slightly less crappy!

Postby heavywoody » Thu Jun 13, 2013 8:38 pm

I was able to get 32mpg on my trip to MI, through the Smokies here... it'll be interesting to see what I get going through the flatlands.

Glad to see you're making it out Brad. Mary coming with?

See you there!


Geoff
95 Z26 3400 5spd
Beretta Preservation Society - Director of Acquisitions
Image

User avatar
snowblindburd
Registered User
Posts: 1118
Joined: Sun Sep 25, 2005 8:48 pm
Location: Stevens Point, WI
Has thanked: 2 times
Been thanked: 4 times
Contact:

Re: 3400 install. My Z26 is slightly less crappy!

Postby snowblindburd » Thu Jun 13, 2013 10:39 pm

wooowoooh! I'll see you guys there!



User avatar
woody90gtz
Registered User
Posts: 4051
Joined: Thu Jul 11, 2002 8:45 pm
Location: Walton, NY
Has thanked: 4 times
Been thanked: 7 times
Contact:

Re: 3400 install. My Z26 is slightly less crappy!

Postby woody90gtz » Fri Jun 14, 2013 11:21 am

I hit 32mpg on a Boston trip and that included an hour of stop & go on the highway and some hills. 5spd run more revs than the autos though, so you may get better.


Image
91 "SS" 3400/5spd - EP, FFP, TCE, SPEC, DSS, S&S, OBD1, 13s? GEARHEAD dezign

User avatar
Rettax3
Registered User
Posts: 1080
Joined: Mon Oct 22, 2012 3:34 pm

Re: 3400 install. My Z26 is slightly less crappy!

Postby Rettax3 » Fri Jun 14, 2013 1:30 pm

I'm pulling just under 33 MPG on the Yellow Indy, mostly country back-roads and 50 MPH side-highways. Pretty hilly country though, or I would see higher than that. The car is an unmolested (and newer, supposedly ~50k mile engine, I'm inclined to believe it with how the car runs) 3.1 with a TH125 auto (for now). It does get even better than that on the highway, about 55-57 MPH seems to be the car's sweet-spot for MPG. My 'old' '88 Camaro got 26.5 highway MPG after I dropped-in the 350, and it didn't care if I was running 55 or 95, it got the same. City was 22.5 MPG, very good for a 5.7 litre V-8, especially an un-rebuilt one with over 300,000 miles! Not sure what she is getting now with the ported Cross-Fire Injection manifold, but she's got a lot more power using the same ECM and injectors, Throttle Body CFM is overall the same I think, (although the CFI separates them and puts them in opposite corners instead of in the middle of the manifold) so I would think that is an indication of higher efficiency...

Oooohhh, this hurts -I can't believe I won't be able to make bfest yet again! Colorado would have been doable almost any other year too, except for these last two. Oh well, you can't have everything... :cry:


1989 Super Charged 3800 Series II (First)Six-Speed Conversion GTU
1990 Turbo 3.4 Five-Speed T-Type
1990 4.0L 4-Cam 32-Valve V-8 Five-Speed Indy GTi (Rebuild Project)
1990 Stock(!) 3.1 MPFI Auto Indy
1995 3400 Top-End Auto OD Z-26

User avatar
Godlike
Registered User
Posts: 176
Joined: Tue Apr 08, 2008 10:02 am
Location: Stoughton, Wi
Contact:

Re: 3400 install. My Z26 is slightly less crappy!

Postby Godlike » Fri Jun 14, 2013 9:44 pm

heavywoody wrote:I was able to get 32mpg on my trip to MI, through the Smokies here... it'll be interesting to see what I get going through the flatlands.

Glad to see you're making it out Brad. Mary coming with?

See you there!


Ya Marys coming. Had to get tires today... one lost 20psi in 2 days. Couldn't find any leak around the valve stem or the rim so im $620 poorer now. Yay! Wish we were bringing a manual trans car for the mountains but ive spent alot of time on this car in the past 6 months.


90' GTZ 189whp NA 14.00@99 / 237whp 50 shot 13.3@104 /95' Integra 225whp / 69' Impala / 04' Z71 Tahoe/ 85 G20/ 15' IS350F
projects 86 Bonneville 6.0 swap / MkIII Supra LS1 swap


Return to “Performance Mods”

Who is online

Users browsing this forum: No registered users and 5 guests