Engine wants to rev up again, have no idea why...

Have a flashing light? Gauges acting funny? Bad idle? Get your problems solved...
Beretta1234567
Registered User
Posts: 389
Joined: Sun Apr 15, 2012 11:40 am

Engine wants to rev up again, have no idea why...

Postby Beretta1234567 » Fri Nov 20, 2015 7:50 pm

1996 Beretta 3100 v6 automatic

Replaced:
Throttle position sensor (No Change).
Idle air control (No Change).
ECM (Problem was fixed).

Engine revs up to 2800 RPM, however only if I get the car on the freeway (Typical freeway speeds 65-70 MPH).

temporary fix:
Put car in neutral and turn engine off, wait about 5-10 seconds, turn engine back on.
Last edited by Beretta1234567 on Thu Apr 21, 2016 2:43 pm, edited 1 time in total.



Beretta1234567
Registered User
Posts: 389
Joined: Sun Apr 15, 2012 11:40 am

Re: Engine wants to rev up again, have no idea why...

Postby Beretta1234567 » Sat Nov 21, 2015 5:35 pm

We checked my car up against a known good Beretta, everything was the same. However when my problem happened sometimes it would not be 0% throttle position at 0%. It read 5% at 0% throttle.
Last edited by Beretta1234567 on Thu Apr 21, 2016 2:43 pm, edited 1 time in total.



User avatar
3X00-Modified
Administrator
Posts: 10664
Joined: Thu Jul 05, 2007 9:18 am
Location: Plainfield CT
Has thanked: 12 times
Been thanked: 46 times

Re: Engine wants to rev up again, have no idea why...

Postby 3X00-Modified » Sun Nov 22, 2015 9:47 am

GHOSTOWLGRID wrote:Do not buy aftermarket electronic parts if you can help it.


You do realize AC Delco is also considered aftermarket parts right?? They are not made in the US or by GM. The rule of thumb is do not buy the cheapest electronic part that you can find. I have a mix of Delco, Standard Motor Products and even Dorman.



Beretta1234567
Registered User
Posts: 389
Joined: Sun Apr 15, 2012 11:40 am

Re: Engine wants to rev up again, have no idea why...

Postby Beretta1234567 » Tue Nov 24, 2015 11:34 am

I always considered them as close to oem as possible without buying dealer oem.

Car still has the problem. Showed up again.
No SES lights or codes ever when this problem happens.
Only fix is turn it off and on again.
Last edited by Beretta1234567 on Thu Apr 21, 2016 2:44 pm, edited 1 time in total.



User avatar
ifixalot
Registered User
Posts: 534
Joined: Tue Dec 26, 2006 10:56 am
Location: Deerfield Illinois
Been thanked: 12 times

Re: Engine wants to rev up again, have no idea why...

Postby ifixalot » Tue Nov 24, 2015 2:10 pm

Rap on the coolant tank with a mallet to fee the stuck level float unless your magnet separated from the float.
I assume, the float gets stuck in muck at the bottom of it's travel.
Are you losing coolant? If the lower intake has loosened, it can have an air leak and also loose coolant.
As far as your high rpm, did you look at the connection to the ECM for corrosion. I had this same issue on a 90 Beretta
that was caused by corrosion.
Another thing to check, there is a plastic pipe that runs from the PCV to the top of the throttle valve. The grommet
on top of the throttle valve rots and sometimes that pipe can allow air. That plastic pipe also
gets brittle and can crack. Maybe you have a crack that opens up with high vacuum but then closes
when you turn the engine off and vacuum goes to zero.
How is your hose that goes to the power brake booster?
Thats all I can think off.



User avatar
themixer
Registered User
Posts: 1520
Joined: Fri Aug 14, 2009 12:13 pm
Location: Truro, Nova Scotia. Canada
Has thanked: 3 times
Been thanked: 16 times

Re: Engine wants to rev up again, have no idea why...

Postby themixer » Tue Nov 24, 2015 2:54 pm

how are you testing for vacuum leaks?



User avatar
1988GTU
Registered User
Posts: 2744
Joined: Sat Mar 23, 2002 1:06 pm
Location: A town up north
Has thanked: 18 times
Been thanked: 11 times

Re: Engine wants to rev up again, have no idea why...

Postby 1988GTU » Tue Nov 24, 2015 5:44 pm

Replace EGR.


_________
Image
-------------

User avatar
3X00-Modified
Administrator
Posts: 10664
Joined: Thu Jul 05, 2007 9:18 am
Location: Plainfield CT
Has thanked: 12 times
Been thanked: 46 times

Re: Engine wants to rev up again, have no idea why...

Postby 3X00-Modified » Wed Nov 25, 2015 11:29 am

1988GTU wrote:Replace EGR.

I was going to suggest at least checking it to make sure it's not sticking open.

GHOSTOWLGRID wrote:Every engine parameter reads correctly no matter what.


You also state this but what parameters are you scanning and what values are you seeing? Whats the IAC count when this is happening? Whats the IAC count when it's idling normally?



Beretta1234567
Registered User
Posts: 389
Joined: Sun Apr 15, 2012 11:40 am

Re: Engine wants to rev up again, have no idea why...

Postby Beretta1234567 » Wed Nov 25, 2015 9:34 pm

Unfortunately, the IAC count is the only thing my scanner can't read.

How would a stuck open EGR cause the car to behave?
How can I check this?
Last edited by Beretta1234567 on Thu Apr 21, 2016 2:45 pm, edited 1 time in total.



User avatar
1988GTU
Registered User
Posts: 2744
Joined: Sat Mar 23, 2002 1:06 pm
Location: A town up north
Has thanked: 18 times
Been thanked: 11 times

Re: Engine wants to rev up again, have no idea why...

Postby 1988GTU » Thu Nov 26, 2015 6:21 pm

You can make a set of block off gaskets to eliminate the flow from the exhaust to intake manifold by cutting a sheet of gasket material and placing one piece on one end and the other gasket piece you will make on the other end. It'll likely toss a code once the EGR is enabled, but it should not allow it to leak any since you've isolated the possible leaking points.


_________
Image
-------------

Beretta1234567
Registered User
Posts: 389
Joined: Sun Apr 15, 2012 11:40 am

Re: Engine wants to rev up again, have no idea why...

Postby Beretta1234567 » Sat Dec 05, 2015 11:02 am

I havent had time to block off the EGR Yet, I have been really bussy, I did get time to check codes again.

New development, MAF low input code 102 showed up after a week or two of the revving problem not happening.

Possible the MAF was reading low enough the engine revved up to compensate and now it got bad enough to throw a code and doesn't rev up anymore because it knows its a bad reading?



User avatar
ifixalot
Registered User
Posts: 534
Joined: Tue Dec 26, 2006 10:56 am
Location: Deerfield Illinois
Been thanked: 12 times

Re: Engine wants to rev up again, have no idea why...

Postby ifixalot » Sat Dec 05, 2015 2:34 pm

I had a bad connector on my maf. I don't remember the code but I would also get a bad hesitation
and a couple times my engine died while in a turn. I don't think the maf is your problem.
I pulled the connector on mine and bent the pins just a little and the problem hasn't come back.



Beretta1234567
Registered User
Posts: 389
Joined: Sun Apr 15, 2012 11:40 am

Re: Engine wants to rev up again, have no idea why...

Postby Beretta1234567 » Tue Dec 08, 2015 11:25 am

I havent had time to check the maf plug to make sure its good.
Or blocking the egr to test for it being stuck open?
I have to hold the gas pedal a bit to keep it from stalling and I hold the idle about 750 rpm.
Last edited by Beretta1234567 on Thu Apr 21, 2016 2:46 pm, edited 1 time in total.



User avatar
ifixalot
Registered User
Posts: 534
Joined: Tue Dec 26, 2006 10:56 am
Location: Deerfield Illinois
Been thanked: 12 times

Re: Engine wants to rev up again, have no idea why...

Postby ifixalot » Tue Dec 08, 2015 12:13 pm

Stalling/low-no idle problem is likely caused by bad MAF connector.
It would take only minutes to unplug the MAF connector and re-connect and see if it helps. Heck just wiggle it and see if things change.
It would take only minutes to cut up an aluminum can to make a thin gasket, loosen the egr and slide it under it to block the egr passage.
It just has to fit in between the bolts of the EGR.
It doesn't need to be fancy, it's just an aid to trouble shooting. If it doesn't help, take it back out.
Yes, it's possible for a bolt to loosen maybe several have loosened and multiple ports are leaking. Who knows?
Good luck.



Beretta1234567
Registered User
Posts: 389
Joined: Sun Apr 15, 2012 11:40 am

Re: Engine wants to rev up again, have no idea why...

Postby Beretta1234567 » Sun Dec 20, 2015 4:58 pm

Unplugged the MAF and readjusted the pins and it doesn't seem to throw any MAP codes anymore.
No more stalling on a warm/hot start.
I'll have to test it some more to make sure the revving stopped for good.




Return to “Diagnostic Help”

Who is online

Users browsing this forum: Google [Bot] and 3 guests