all Lights not working etc...

Have a flashing light? Gauges acting funny? Bad idle? Get your problems solved...
Chevyrider215
Registered User
Posts: 5
Joined: Sun Dec 11, 2016 7:16 am

all Lights not working etc...

Postby Chevyrider215 » Sat Jun 17, 2017 8:22 am

I have a 90 Beretta Indy and last night I experienced the unusual ,I was pulling out of my dads neighborhood when all of a sudden something triggered making the car buck a lil and shutting everything down and what I mean by that is all the lights in the dash ,headlights, interior lights and radio all are not working now it even must of knocked out the fans cause after sitting at idle the car began to run hot but I immediately shut of the engine so I asked around and a few told me something about a possible fuse-able link could have went bad ??? I dunno I'm no wiring expert but the car starts and runs I do have brake lights and signals along with working hazards but those are the only things that's working "light" wise so If anyone on here have had or experienced something like this please give me some ideas on what to diagnosed ,I'll be figuring things out on my end thanks...



User avatar
ifixalot
Registered User
Posts: 536
Joined: Tue Dec 26, 2006 10:56 am
Location: Deerfield Illinois
Been thanked: 12 times

Re: all Lights not working etc...

Postby ifixalot » Mon Jun 19, 2017 9:14 am

My 90 Service manual shows two wires attached to the threaded post, along heavy wire from the battery on the starter.
You check if those are loose or one broke off or maybe one shorted and burned through.



Chevyrider215
Registered User
Posts: 5
Joined: Sun Dec 11, 2016 7:16 am

Re: all Lights not working etc...

Postby Chevyrider215 » Tue Jun 20, 2017 9:29 am

I noticed that the both + - terminals were loose so i tighten those but still no power going to anything the car starts and when i turn the key on some of the lights come on the dash but I'm still not getting any lights or no power to the radio ..i checked the fuses and relays on the side dash panel and they were all good



GT_Indy
Registered User
Posts: 274
Joined: Thu Apr 21, 2016 2:23 pm
Been thanked: 2 times

Re: all Lights not working etc...

Postby GT_Indy » Tue Jul 04, 2017 9:48 am

I don't remember which pins power which circuits, I will see if I can locate another 90 book as my gtz is a 90 and I gave my only 90 Beretta shop manual with the turbocharged Indy that I sold.
Take a multi-meter and check the fuses and fusable links to see if any are broken.
Last edited by GT_Indy on Mon Jul 10, 2017 9:56 pm, edited 1 time in total.


Mint White 1990 Beretta GTZ Quad4 5-spd
Mint Yellow 1990 Beretta Indy 3.1 auto, Digital Dash, Sunroof.
Clean 1996 Beretta (Z26 swap) 3100 auto.

GT_Indy
Registered User
Posts: 274
Joined: Thu Apr 21, 2016 2:23 pm
Been thanked: 2 times

Re: all Lights not working etc...

Postby GT_Indy » Mon Jul 10, 2017 9:54 pm

I got a hold of some schematics.

Headlights, interior lights, and radio look to be running off of fusible link D in the schematic below.

20170710_213540.jpg


Get a multi-meter and set it to check DC voltage, minimum 20 volts setting.
Open the engine hood and look at the relays on the firewall, locate the 12 volt terminal on the firewall, this should have 12 volts.
Note that there are 2 fusible links on that terminal.

What the schematic shows is fusible link D, it looks like this link is located at the starter motor "+" terminal. If you can locate this link, see if it is blown, if it is blown it needs replaced with a new one at the proper amperage. If the replacement pops, check for to much current draw or shorts, sometimes something as simple as changing to an aftermarket radio can make these pop.

See the below image for radio wiring, check for power on the orange battery input wire according to the schematic.

20170710_213849.jpg


Check fuses in the driver door jam for 12 volts, look at fuse 11 and fuse 7 and see if they have 12 volts, if not then its a good chance that the fusable link D is broken and needs replaced.

If you have a 1990 Beretta Indy service manual reference the electrical section in pages 8A-10 for power distribution, and 8A-150-0 for Battery, and the headlights are in there as well.

Check power wires to known grounds like a bare metal spot on the body, use a working 12 volt source to verify grounds with the multi-meter.

I had this same issue on my older Cadillac, except the fusible link didn't pop, the wire going into it corroded inside the insulation right next to the link as they separated enough from age. If Link D is at the starter solenoid, its possible that its more prone to premature age.


Mint White 1990 Beretta GTZ Quad4 5-spd
Mint Yellow 1990 Beretta Indy 3.1 auto, Digital Dash, Sunroof.
Clean 1996 Beretta (Z26 swap) 3100 auto.

Chevyrider215
Registered User
Posts: 5
Joined: Sun Dec 11, 2016 7:16 am

Re: all Lights not working etc...

Postby Chevyrider215 » Thu Jul 27, 2017 5:53 pm

I found that the connector to the cooling fan relay was melted so could that be the problem ?as far as the fans not working? I'm a look and trace the lights as well




Return to “Diagnostic Help”

Who is online

Users browsing this forum: No registered users and 4 guests