90 gtz is dead

Archived topics from the Diagnostic Help Forum
User avatar
woody90gtz
Registered User
Posts: 4032
Joined: Thu Jul 11, 2002 8:45 pm
Location: Walton, NY
Has thanked: 4 times
Been thanked: 7 times
Contact:

90 gtz is dead

Postby woody90gtz » Mon Jul 07, 2003 7:40 am

quad4 5spd

turn the key and nothing happens. interior & exterior lights come on at a very low intensity and there seems to be no juice at all. i jumped it and that didnt work. i let the truck jumping me run for 15 mins while it was connected to mine and it still didnt work. then i charged the battery overnight and that didnt work either. the charger also read that the battery was fine. so i guess my battery is fine but the problem acts as if it wasnt. twice my interior lights would come on at full power and then 2 minutes later you couldnt even tell they were on.

does anyone have a clue what this might be or had this problem before? im stumped. my only guess is a loose power wire somewhere. please help, i have someone that is looking to test drive it soon.


Image
91 "SS" 3400/5spd - EP, FFP, TCE, SPEC, DSS, S&S, OBD1, 13s? GEARHEAD dezign

Guest

90 gtz is dead

Postby Guest » Mon Jul 07, 2003 8:22 am

I would be willing to bet you have some serious corrosion aroun dyour battery terminals--or one is loose.



Guest

90 gtz is dead

Postby Guest » Mon Jul 07, 2003 1:00 pm

yep...that's what happened on my z26...i would try to start it when i first got it and everything was dim and it would just click. i thought the starter was going out at first but i cleaned my battery terminals and tightened them down properly. it's been great starting since...



User avatar
woody90gtz
Registered User
Posts: 4032
Joined: Thu Jul 11, 2002 8:45 pm
Location: Walton, NY
Has thanked: 4 times
Been thanked: 7 times
Contact:

90 gtz is dead

Postby woody90gtz » Mon Jul 07, 2003 11:10 pm

real easy fix...
the battery is kinda stripped on the side + terminal, i just tightened it up more and it is fine now.
i dont know why i didnt think to check that last night.... probably too tired from work, lol


Image
91 "SS" 3400/5spd - EP, FFP, TCE, SPEC, DSS, S&S, OBD1, 13s? GEARHEAD dezign


Return to “Diagnostic Help Archive”

Who is online

Users browsing this forum: No registered users and 1 guest