1994 beretta z26 cranks but won't start

Have a flashing light? Gauges acting funny? Bad idle? Get your problems solved...
Froutranger25
Registered User
Posts: 1
Joined: Thu Sep 02, 2021 7:42 pm

1994 beretta z26 cranks but won't start

Postby Froutranger25 » Thu Sep 02, 2021 8:01 pm

So my dad has an old white 1994 beretta z26 manual, and he said i can have it if I can get it running, so challenge accepted. The problem is, is that it cranks but won't start. I already check the spark that's all working, so is the computer because the check engine light goes on, I'm unable to read the codes though. Might try the paper clip thing. The fuel pump is working, because i think I hear it, when I turn the key. Also it almost starts when I play around with the gas. Also there is an oil leak passenger side, I was thinking it was an oil pan gasket, or the timing chain cover gasket. But then I noticed oil in the the spark plug cylinder. Witch is normally a valve cover gasket, but who knows everything about this car stumps me. Any suggestions?



User avatar
Rettax3
Registered User
Posts: 1669
Joined: Mon Oct 22, 2012 3:34 pm

Re: 1994 beretta z26 cranks but won't start

Postby Rettax3 » Mon Sep 06, 2021 4:44 am

Still could be ignition. Since the Z-26 was only offered with a manual with the Quad-4 engine, that means you have a really rare car, VERY worth fixing, but it also means you have GM's crappy IDI ignition system, which housed both ignition coils in a plastic distribution 'block', or 'fork' between the cam-housings and under the IDI cover (aluminum plate ID-ing the engine as a Quad). That plastic 'fork' can break-down internally, allowing spark to short from one coil post to the other post, completely bypassing the spark-plugs. During a spark-check, it might all appear okay, but put compression in the cylinders, and the spark can decide it has less resistance through the failing housing. I have retro-fitted GM's conventional post-type coils with conventional ignition wires to ditch this housing on a couple of these engines... So you may still need to look into the ignition system some more.

Other than that, fuel or compression are your likely culprits. IIRC, '94 didn't offer a fuel-pressure service-port on the Quad, if that is the case, you might need to splice into the fuel-line to add a port (I used compression-type fittings with NPT (National Pipe Thread) adapters, put a brass TEE in-line on the metal supply-side and installed a permanent test-port on my '97 Z-24 Twin Cam, which has the 2.4 Liter successor to the 2.3 Quad in your '94 Z. Other methods exist too, for checking fuel pressure while dead-heading the system (basically plugging a gauge into the fuel supply line so it doesn't reach the fuel-rail or FPR). I don't like that method though, it doesn't test the FPR and I feel can damage a weak or aging pump.
Next, pull the vacuum-line off of the FPR itself, crank the engine a few times and look for fuel coming out -the FPRs are known for failing and leaking internally, which will prevent the fuel system from generating proper pressure, as well as dumping raw gas into the engine via the vacuum line to the FPR. After that, get a set of NOID lights (buy them, or borrow a set from your local auto-parts store from their loan-a-tool program, and verify that the fuel injectors are actually getting a signal from the ECM.
Lastly, perform a compression test, check all four cylinders. Your Quad uses a timing-chain, it is very unlikely to have skipped time. However, the Quads are known also for blowing head gaskets, and if you are drowning the spark-plugs in coolant, your engine may not start at all, so check your plugs too.
Other than that, welcome to the Forum. It is pretty slow here these days, but there are a few of us die-harders left here, so we are here to help and share. Hopefully you can get it running, and can show some pictures of the car -we always love seeing those! Good luck.


1989 SuperCharged 3800 Srs-II (First)Six-Speed GTU
1990 Turbo 3.4 5-Speed T-Type
1990 4.0L 4-Cam 32-Valve V-8 5-Speed Indy GTi (Project)
1990 Stock(!) 3.1 MPFI Auto Indy
1995 LA1/L82 4T60E Z-26
1995 3.4 DOHC Turbo 5-Speed Z-26


Return to “Diagnostic Help”

Who is online

Users browsing this forum: No registered users and 6 guests